Situação
O sistema não está realizando a importação e o cálculo das marcações.
- Ao executar a importação, as marcações não são processadas para os contratos.
- O processo de importar marcações online ou por arquivo com cálculo é finalizado sem erros, com a mensagem de processo concluído com sucesso.
- No entanto, as marcações não são efetivamente importadas.
- O log da importação confirma que o processo foi realizado sem erros.
- Ao inserir marcações de teste e realizar o cálculo, o sistema finaliza sem erro, mas não realiza o cálculo corretamente, não trazendo os dias completos do período selecionado.
Causa
É necessário validar se a atualização do sistema foi realizada de forma correta.
Exemplo:
Se o cliente atualizou o sistema utilizando o executável x64 bits e o banco de dados utilizado é Oracle, nesse caso, o correto seria utilizar o executável x32 bits.
Como verificar o formato do banco de dados:
- Acesse a tela inicial do SIRH Metadados.
- Vá em Opções > Alias do Banco.
Como verificar a plataforma utilizada pelo processo de cálculo:
- Abra o Gerenciador de Tarefas do Windows.
- Localize o processo CalculoFA.
- Clique com o botão direito na barra de colunas e selecione Selecionar colunas.
- Na janela exibida, habilite a coluna Plataforma.
- Verifique se o sistema está utilizando a versão correta (x32 ou x64).
Solução
Realize a atualização do sistema com os pacotes correspondentes ao formato do banco de dados:
- Para SQL Server: utilizar pacotes x64
- Para Oracle: utilizar pacotes x32
Se já estiverem sendo utilizados os pacotes corretos conforme o banco de dados, será necessário realizar uma nova atualização com a versão mais recente disponível no Portal do Cliente.