Situação:
Ao cadastrar um novo contrato após virada de chave ocorreu a inconsistência abaixo quando clica para Salvar o cadastro:
=> O Evento Retificador Deve Referir-se ao Mesmo Vínculo (CPF + Matrícula) do Evento a Ser Retificado
Motivo:
Esse erro ocorre, pois, o contrato anterior já possui a matrícula eSocial informada e para o novo contrato deveria seguir a numeração, mas puxa a mesma matrícula.
Exemplo: Contrato 517 com a matrícula eSocial 236.
E ao cadastrar o novo contrato, puxa a mesma matrícula:
Solução:
1. Solicite um orçamento junto ao time de serviços, visto que serão necessárias intervenções em várias tabelas no banco de dados para ajuste de matrícula eSocial e que o sistema volte a puxá-la na sequência.