Situação
No módulo Frequência, ao acessar o menu: Consultas > Histórico de Cálculo e tentar importar marcações, o sistema conclui a operação, mas não aloca as marcações, ou conclui alguns arquivos com êxito e apresenta erros em outros.
Sendo um deles:
Importação de Arquivos - Não foi possível renomear o arquivo "D:\META\COLETA\COLETORXXX\AFDColetaMarcacoesColXXX.txt". O sistema não pode encontrar o arquivo especificado.
Causa
Isso pode ocorrer por vários motivos: arquivo fora do formato, problemas de rede, processos sobrepostos, processos travados no servidor, erro no banco SCQ_Meta, etc.
Solução
Passo a Passo
1. No módulo Frequência, consulte o diretório dos coletores no menu: Arquivo > Tabelas do Ponto > Modelo de Coletores.
1.2 Verifique se, no diretório informado, as Pastas de Coletas estão com espaços ou caracteres especiais.
- Caso estejam, renomeie-as retirando os espaços e caracteres especiais, deixando conforme o exemplo abaixo.
2. Após isso, acesse novamente: Arquivo > Tabelas do Ponto > Modelo de Coletores.
2.1 Informe o diretório com as pastas corrigidas.
3. Em seguida, vá em: Arquivo > Tabelas do Ponto > Coletores.
3.1 Informe o novo diretório na tela de Cadastro dos Coletores.
4. Para realizar novamente a importação, verifique a descrição dos arquivos já gerados e se há necessidade de renomeá-los.
- Às vezes, é possível reimportar os arquivos sem precisar renomear; porém, se o arquivo não estiver com a extensão .txt, será necessário renomeá-lo.
5. Por fim, acesse: Apuração > Importar > Com cálculo.
5.1 Selecione poucos arquivos por vez e realize a importação.